SEToolkit

Today, I’ve been exploring the abilities of TrustedSec’s Social Engineering Toolkit which comes packaged within Kali Linux.

The documentation provided is extensive and extremely thorough and helpful. The navigation within the toolkit is user-friendly an intuitive and the number of options is phenomenal! What a serious piece of kit this is! I am certainly looking forward to delving deeper and using its powerful capabilities.

One small issue I have come across, and this is likely a rookie error on my part!, is updating the Toolkit. The startup screen says ‘There is a new version of SET available.’. I’m running 7.6.3 and the current version is 7.6.5, apparently. One of the opening options is ‘4) Update the Social-Engineer Toolkit’ which you’d think would fix this version difference. But selecting that gives the message ‘You are running Kali Linux which maintains SET updates’ and returns me to the startup screen.

I’ve run apt-get update && apt-get upgrade (as I do every evening in a crontab) but this issue persists. On checking the Github page for the SET, there’s a pile of dependencies listed, so I have added those (all were already up-to-date) and I have tried cloning the github repo but this wouldn’t overwrite the existing folder. I also ran the python script to install the toolkit, again, to no avail. There’s an seupdate file in there but I can’t get it to run; maybe I need more info on that.

Do I delete the whole folder and reinstall? That seems somewhat drastic! As with what I opened, this is probably a rookie error and something I’ll learn with more experience, so I’d best get on and gain some.

One thought on “SEToolkit

  1. steve.hunter Post author

    I think this is down to my Kali Linux update preferences. I have the ‘standard’ rolling distribution selected so I receive stable releases. Included tools such as this Social Engineering Toolkit may take a few months to reach this release. Adding the ‘bleeding edge’ repository to the update sources will introduce these changes more quickly. I think that runs a risk of a less stable system, so I’ll pass for now.

    Reply

Leave a Reply

Your email address will not be published. Required fields are marked *